View Full Version : G540: How do I load the mach3mill.xml file into Mach3?

08-31-2010, 03:37 PM
I've got my wiring completed and am trying to get my motors to run, but I've run into a stumbling block.

I've got my straight through parallel cable (verified), g540 with a green light, all 4 motors connected (2 on the X axis, A set to slave in settings), verified my motor wiring to the G540 and followed the Mach3 setup guide for our package PDF on the kelinginc site.

I have not been able to load the mach3mill.xml file from the Kelinginc site. When I try to open it in mach3, it tries to load all on one line and gives the error 'line too long' in a status box. If I try and move the motors with a command like g0 x10 y10 z10, I can see the DROs move on the screen but the motors dont move with it.

Also, my estop works mechanically, but I can't get it to be recognized by mach3. Not sure what to do about that.

Please advise me on what I should try next.


08-31-2010, 03:58 PM
When you start Mach, it will ask you what profile you want to use - Milling, Lathe, etc. When you select the "Mill" option, Mach will load that .xml file for you, AS LONG AS it is in the correct directory.
I believe it should be in the root directory of Mach, but if you'll do a file search for .xml extensions, you will easily discover in which directory they already reside. Obviously, you'll need to turn off the "Hide extensions for known types" button in the Windows "Tools" "Options" "View" screen.

08-31-2010, 04:26 PM
Ahh ok. thank you, I'll give that a shot.

Crevice Reamer
08-31-2010, 04:27 PM
G540.xml download details here:


08-31-2010, 04:54 PM
Thanks for the details. I got the file and put it into the mach3 directory and am able to select it from the mach3 loader screen. So, that's one problem down and more to go.

My g540 is getting too hot to touch within about 5 mintues of turning it on. When I hooked everything up for the first time, my power supply popped and blew out(I have a new one now). I'm concerned that I somehow damaged the G540. I did buy some of those extra fuses from digikey, so I have them at the ready if this is the problem. I also wonder if this is why my estop isn't being recognized in mach3 when I hit it.

Any ideas?

thanks again!

Crevice Reamer
08-31-2010, 06:04 PM
If you have a green light, then the G540 is ok. You may need a fan or heatsink.

Estop must be connected from pin 10 to switch to PSU ground. The .xml file should have set up Mach3 for it. Check ports & pins to be sure.


08-31-2010, 08:31 PM
Thanks! You guys helped me get it working! Now on to more confounding problems... (http://cnczone.com/forums/showthread.php?t=111204)