PDA

View Full Version : Mach 2 Estop problem



dentman
06-05-2005, 08:04 PM
I am getting a message telling me that an external estop has been requested and I am unable to reset the system. I don't have the emergency stop box checked in conf. as I know that is used only offline. No limit switches are triggered and the estop button is out. Any ideas as to what may cause this?

CNC Darren
06-05-2005, 10:10 PM
i had the same problem, in my case i was using it on my main computer and it didnt get along with my HP Laserjet3. I unpluged it from the parallel port and works fine.

Darren

dentman
06-06-2005, 12:36 AM
Darren,
Thanks I appreciate your input. This is a little different though. I have it on a laptop with no printer installed. The laptop has only one parallel port on it. If anything else comes to mind please let me know. Again thank you for your reply.
Rick

JRoque
06-06-2005, 07:37 PM
Hello Rick, if you are referring to the checkbox next to "Emergency Stop" in the "Input Pins" tab of the configuration, you need to have that checked if you don't have an eStop connected. The checkmark is to set the "Active Low" option on that pin. If nothing is connected, the pin will be "high" and Mach2 e-stops. If you check it Mach2 will only e-stop when you connect that pin to ground.

BTW, having an emergency stop is not only a good idea, it's a requirement in Mach2.

JR

dentman
06-07-2005, 12:26 AM
JR,
Thanks for the info. I do have emergency stops on the machine so the emergency stop box under pins and ports is unchecked. I have tried running with the low active box checked and unchecked. I still get the external estop requested. Something that really makes this unusual is that it was running fine, I shut it down and came out the next day and had this problem. I didn't change any settings at all. Thanks so much for your input and if you have other ideas please run them by me.
Rick

JRoque
06-07-2005, 01:57 PM
Hey Rick, try checking the "low active" option and restart Mach2. If that doesn't work, disconnect the parallel cable from the PC side. Any difference? You can also check to see if the port itself is damaged by using a port analyzer. There's a few free ones on the Net and I think I might have one written in VB I can send you, I'd have to look to be sure.

It might also be helpful if you post your Mach2 profile xml file so we can look at it and double check everything.

JR

dentman
06-07-2005, 05:33 PM
Hi Jr,
Thanks for the input. I will try what you suggest and get back to you. It's so wierd that it would be working fine at shut off and then not work at start up with no changes in between. Being it was working wouldn't that indicate that the xml profile is okay? Being it tells me that an external estop has been requested I'm wondering if I have an open circuit somewhere. I'll let you know how it goes and once again thank you for the help. Rick

dentman
06-07-2005, 06:11 PM
JR,
I tried what you suggested and nothing changed. I am posting the xml file you requested. Let me know if you find something suspect. I don't see a copy as an attachment so let me know if you get the file.
Thanks, Rick

JRoque
06-07-2005, 08:13 PM
Hey Rick,

I don't see the attachment. Maybe you need to change its extension to .txt so the forum will take it.

If you disconnected the parallel cable from the PC side and its still tripping the eStop, I can only think of two causes: your LPT port is damaged or there's a bad setting in Mach2. There could be a remote possibility of another piece of software interfering but Mach2 would have complained about that, I'd imagine.

Thanks,
JR

dentman
06-07-2005, 08:32 PM
Hi JR,
I disconnected the cable, no change. I went in and checked the port and it says it's working fine with no interference. I've changed the extension to .txt and tried to upload the profile but I still don't see it. I go to manage attachments and select that file and upload it. After that I have now idea where it went. I thought it would be automatically attached. It's kind of frustrating as I would like you to see the profile. Any ideas?
Thanks,
Rick