Is there a Main Fuse? No Power when turned on


Results 1 to 5 of 5

Thread: Is there a Main Fuse? No Power when turned on

  1. #1
    Registered
    Join Date
    Dec 2014
    Location
    Australia
    Posts
    151
    Downloads
    0
    Uploads
    0

    Default Is there a Main Fuse? No Power when turned on

    I have a X900 Redsail, just looking for the Fuse as no power is getting to the machine

    Similar Threads:


  2. #2
    Registered
    Join Date
    Jul 2016
    Location
    China
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default Re: Is there a Main Fuse? No Power when turned on

    First check main power input voltage,



  3. #3
    Registered
    Join Date
    Jul 2016
    Location
    China
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default Re: Is there a Main Fuse? No Power when turned on

    you can add my skype: dwdcnc_lei@163.com, we can talk,check it step by step



  4. #4
    Registered
    Join Date
    Dec 2014
    Location
    Australia
    Posts
    151
    Downloads
    0
    Uploads
    0

    Default Re: Is there a Main Fuse? No Power when turned on

    Thanks for the reply, I don't have a Volt Meter to check input Voltage,



  5. #5
    Registered
    Join Date
    Dec 2014
    Location
    Australia
    Posts
    151
    Downloads
    0
    Uploads
    0

    Default Re: Is there a Main Fuse? No Power when turned on

    OK found the Fuse ( Thanks YouTube!!! ) and its at the base of where the Power cable goes into the Machine. It certainly is Blown so now I just need to find what rating the Fuse it so I can buy another



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Is there a Main Fuse?  No Power when turned on
Is there a Main Fuse?  No Power when turned on