Need Help! Breakout board input doesn't seem to switch when set to "Home"


Results 1 to 3 of 3

Thread: Breakout board input doesn't seem to switch when set to "Home"

  1. #1
    Registered
    Join Date
    Jan 2017
    Location
    United Kingdom
    Posts
    32
    Downloads
    0
    Uploads
    0

    Default Breakout board input doesn't seem to switch when set to "Home"

    Hi all,

    I'm just building my control panel for my CNC project. I'm a complete newbie to all this and I've come across a small problem.



    I'm using an Arduino Mega as the "brain" of the machine. I want to be able to manually set the machine to "home" via 3 buttons on the control panel (X home, Y home, Z home).



    I've got a generic Chinese Breakout Board.



    Within StepConf I configured pin 11 to be "Home X".



    When the Arduino detects the "X home" button pressed I send an output of 5V to the breakout board. But it doesn't seem to do anything?



    I tried clicking the "invert" box in StepConf but still nothing.



    I tried changing pin 11 to be "E Stop In" in StepConf and I can then see the Estop coming in and out on the LinuxCNC software when I press the "X home" button on my Control Panel.



    I have set a position for x home of 100.0 in StepConf (the motors aren't connected to the machine at the moment as I've not yet built the machine so they can just turn forever without a problem).



    If I go into the software and click "Home X" via the software then the X motor just keeps turning forever (i.e. way past the 100.0 setting). But putting either 5V or Gnd on Pin 11 doesn't mimic this behaviour?



    Anyone know where I'm going wrong with this?



    Thanks for any help you can give as I'm tearing my hair out (what's left of it). I realise it's hard to visualise my set up so if yoU want me to post pictures or more info then please ask.


    Thanks :-)

    Similar Threads:


  2. #2
    Registered
    Join Date
    Oct 2016
    Location
    United States
    Posts
    26
    Downloads
    1
    Uploads
    0

    Default Re: Breakout board input doesn't seem to switch when set to "Home"

    I think you are misunderstanding the home concept with the breakout board/linuxcnc.
    -linux cnc starts a home command move (from the main linuxcnc screen) -moves one of the axis and waits until the home switch on that axis closes(which is connected to pin 11 in your case) and then knows it is homed.
    setting the X home position to 100 means after the home move, linuxcnc will identify the current X position as 100 after homing
    I set my 0 X limit as my home and after i home the x then the x displays 0.00. and the table has moved to its right direction limit(it helps that i used the switch on the lefthand side of the table!!)



  3. #3
    Registered
    Join Date
    Jan 2017
    Location
    United Kingdom
    Posts
    32
    Downloads
    0
    Uploads
    0

    Default Re: Breakout board input doesn't seem to switch when set to "Home"

    Quote Originally Posted by jimairth View Post
    I think you are misunderstanding the home concept with the breakout board/linuxcnc.
    Yep, that is exactly what was happening Jim. Thanks for the help. I managed to sort it last weekend with a bit of swearing, hair pulling and the help from another CNC forum.

    Thanks again mate :-)



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Breakout board input doesn't seem to switch when set to "Home"
Breakout board input doesn't seem to switch when set to "Home"