Rebuild log Universal Laser Systems 25PS - Page 4

Page 4 of 4 FirstFirst 1234
Results 37 to 43 of 43

Thread: Rebuild log Universal Laser Systems 25PS

  1. #37
    Registered
    Join Date
    Feb 2016
    Location
    United Kingdom
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Quote Originally Posted by cgerber View Post
    b. Regarding the X / Y limit switches - what voltage do they need 24V? and do they need any current limiters (in line resistors?)
    These are photo detectors; Omron EE-SH3
    .
    Thanks Chris
    If I had taken one off to investigate I might have spotted this sooner !! In the end I had to remove it to figure out the wiring
    and I discovered the Anode/Cathode Emitter/Collector were clearly marked (with a magnifying glass) on the underside of the photo detector.
    I built a little resistor array circuit to control them using the 5V off the DSP and it seemed to work OK.

    I have a small issue now in that the Y limit is reached first and the X limit isnt tripped because its too far away.
    Im hoping that I can tell it that the Y limit is -25 mm back so the X can trigger too. If you set it manually ie push the Y
    all the way home - the X does stop correctly. The DSP instructions arent very helpful.

    I note you changed the Y motor for one that does 0.9 degree steps instead of the 1.8 degree one it comes with.
    Did that improve the accuracy or speed etc. I dont want to spend money unless there is some gain :-)

    regards
    Adrian



  2. #38
    Registered
    Join Date
    Mar 2013
    Location
    USA
    Posts
    18
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Hi Adrian,

    I am not familiar with the controller you have, so I am not sure that I understand the homing problem you are having.

    Regarding my Y motor, I think this is the original Y motor that came on the machine. I bought my machine second hand, but I don't think the Y motor was ever changed. I am pretty sure it is needed at 0.9 degree steps for accuracy and resolution. Is your Y motor 1.8 degree?

    Thanks. Chris...



  3. #39
    Registered
    Join Date
    Feb 2016
    Location
    United Kingdom
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Hi Chris
    On closer inspection my motors are the same as yours - both X and Y steppers 0.9 degree.
    Im impressed that these were already fitted 15years ago - a very nice starting machine indeed. I have upped my micro stepping to 3600 to match.

    The homing problem is because the Y sensor beam gets broken whilst the carriage is about 30mm off the back wall and stops
    and so the X sensor beam never gets broken because its too far away. So I sort of need to tell it the true Y origin is - 30mm so it travels a bit further.

    Heres a crude drawing
    Rebuild log Universal Laser Systems 25PS-datumproblem-png

    regards
    Adrian



  4. #40
    Registered
    Join Date
    Mar 2013
    Location
    USA
    Posts
    18
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Hi Adrian,
    I see, the homing you are describing makes sense to me now. I ran into this same problem when I upgraded to DSP control. I am not sure exactly why, as this was a couple years ago for me, but I wonder if the original control had some sort of delay, or traveled extra steps after first seeing the flag. I fixed it on my machine by drilling and tapping new mounting holes and relocating the photo eyes. It is interesting in that I had to relocated both the X and Y home photoeyes, about the same distance for both if I remember correctly.

    Chris..



  5. #41
    Registered
    Join Date
    Feb 2016
    Location
    United Kingdom
    Posts
    5
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Quote Originally Posted by cgerber View Post
    Hi Adrian,
    I see, the homing you are describing makes sense to me now. I ran into this same problem when I upgraded to DSP control. I am not sure exactly why, as this was a couple years ago for me, but I wonder if the original control had some sort of delay, or traveled extra steps after first seeing the flag. I fixed it on my machine by drilling and tapping new mounting holes and relocating the photo eyes. It is interesting in that I had to relocated both the X and Y home photoeyes, about the same distance for both if I remember correctly.

    Chris..
    Hi Chris
    In the end I decided to move the Y sensor back 30mm - which helped with the X axis most of the time !!
    The trouble I have now is that if the X is already near that end - it hits the bar until Y arrives at home.
    I have decided to fit an IR proximity device for X at the opposite end from where it is now ( more logical 0,0 point with the ruler ) - that way it just has to break the beam rather than physically locate. Will finally try the laser this weekend and see if it has any life left ?!

    Adrian



  6. #42
    Registered
    Join Date
    Sep 2005
    Location
    USA
    Posts
    238
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Quote Originally Posted by LaserBoyUK View Post
    Hi Chris
    In the end I decided to move the Y sensor back 30mm - which helped with the X axis most of the time !!
    The trouble I have now is that if the X is already near that end - it hits the bar until Y arrives at home.
    I have decided to fit an IR proximity device for X at the opposite end from where it is now ( more logical 0,0 point with the ruler ) - that way it just has to break the beam rather than physically locate. Will finally try the laser this weekend and see if it has any life left ?!

    Adrian
    Adrian I have a working V460 ULS laser in my shop I if you need any voltage readings or something I can look at on this machine just let me know. I am in the process of getting a small China made rotary working and all I need is just what wire or pin do I need to ground or otherwise to make the machine recognize the rotary. I have the stepper motor wiring hooked up and on boot up it rotates and then locks the steppers in the material holding mode.

    Bill G in Iowa



  7. #43
    Registered wireb's Avatar
    Join Date
    Dec 2010
    Location
    USA
    Posts
    153
    Downloads
    0
    Uploads
    0

    Default Re: Rebuild log Universal Laser Systems 25PS

    Project is not dead yet.
    Had some time while waiting on parts for another project so pulled out the stepper driver plate and worked on it some more.
    I think I am going to go with a motion board (smoothie board family) as the controller as they now have support for rastering.





Page 4 of 4 FirstFirst 1234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

Rebuild log Universal Laser Systems 25PS
Rebuild log Universal Laser Systems 25PS