Results 1 to 12 of 12

Thread: Problem Hitachi Seiki HT 40G

  1. #1
    Registered
    Join Date
    Feb 2005
    Location
    Spain
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default Problem Hitachi Seiki HT 40G

    The first thing to ask perdon by my bad English I am used a program for translation.
    I working in Hitachi Seiki HT40g Seicos-10L Multi
    My question is:
    When I write a program with angles or cycle for drilling ,the program is stoped leaves an alarm NC alarm [191] Option command

    NC alarm [191] Option command G01A Whith angles
    NC alarm [191] Option command G80N Whith cycle for drilling

    The rest of g-codes and options run well,i dont understand this?
    I have lost parametres?
    where I go for activate this?
    someone can help me to cause to run the options.
    Thanks to all

    Similar Threads:


  2. #2
    Registered
    Join Date
    Jun 2008
    Location
    United States
    Posts
    1509
    Downloads
    0
    Uploads
    0

    Default

    Are you sure it is not the program? Can you post the code that you are having a problem with?

    If it is a parameter issue I will dig around and see what I can find. I don't know how much I have on the HT40 but I have a lot on the VK45,55,65.

    Stevo



  3. #3
    Registered
    Join Date
    Feb 2005
    Location
    Spain
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default

    Thanks for you response,is not a problem of programation,whith the original books i write the same examples and don´t work.



  4. #4
    Registered
    Join Date
    Jun 2008
    Location
    United States
    Posts
    1509
    Downloads
    0
    Uploads
    0

    Default

    Just for the heck of it can you post the example code you are trying and show were it does not work or alarming out?

    Stevo



  5. #5
    Registered
    Join Date
    Feb 2005
    Location
    Spain
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default

    Ok,tomorrow i post the examples.



  6. #6
    Registered
    Join Date
    Feb 2005
    Location
    Spain
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default

    Hi,the angle format is
    G01 x_ A_;
    G01 z_ A _;
    Example:
    G0 x50 z10
    G01 x52 z-1.5
    z-10
    x60 A150
    z-60
    Drilling command format
    G198/G199 G_ X_ Z_ R_ D_ Q_ P_ L_ F_ E_;
    peck drilling example
    G0 X0 Z10
    G198 G83 X0 Z-30 Q-5 F0.15;
    of this example I doubt because never has functioned,because the books are in English and I doubt of the traduccion that I do.
    It writes as programs your these same examples to see if there is some variacion.
    Thanks



  7. #7
    Registered
    Join Date
    Jun 2008
    Location
    United States
    Posts
    1509
    Downloads
    0
    Uploads
    0

    Default

    Sorry for the late reply.

    I have never programmed an angle with A before. I see that you have X,Z moves in the same line. Is there any alarms with that code? If not can you program your angles by moving the 2 axis?

    I am not sure about the G198/G199. Try programming without them. Just remove the G198. Also try putting in a R value. This is your start position before feeding. I usually set mine to .1. Is Q your pick? Is it suppose to be negative? I have never set my pick negative in the canned cycle.

    G0 X0 Z10
    G83Z-30 R.1 Q-5 F0.15;

    Stevo



  8. #8
    Registered
    Join Date
    Feb 2005
    Location
    Spain
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default

    Hi,i have another two fanuc controls,and the funtion of angle is the same
    G00 X20 Z3
    G01 X25 Z-1.5
    Z-20
    X30 A150
    Z-40 A90
    This example run,but in the hitachi not run, is a fanuc control serie 180.

    Whith the drilling i am not sure for the programation,never I have arrived has to run,Q is depth of cut.
    How do you write the cycle for drilling G83 in the control of your Hitachi?
    I try your example and i spoke you if has functioned.



  9. #9
    Registered
    Join Date
    Jun 2008
    Location
    United States
    Posts
    1509
    Downloads
    0
    Uploads
    0

    Default

    I am not sure about the angle. I will have to do some reading up on that. Or if anyone wants to chime in and enlighten us. Most of my experience with Hitachi is on mills.

    As to the drilling yes the Q is the depth of cut during a pick. The Z is still the final depth. I also see that you have no R but you are doing a standard pick with the G83 cycle. You should have a R to specify the return amount after each pick. I have never run a G83 with no R. If you were highspeed peck drilling then the return amount after each pick is usually controlled via parameters. Try the code below.

    G0 X0 Z10
    G83Z-30 R1 Q5 F0.15;

    Should take you to a depth of 30 and pick every 5 to a return amount of 1 at a feed of .15. You can also put in a G98 as to return to initial plane(10) when complete. I have my controls default to G99 so I usually forget to specify that when explaining as I am not use to inserting that in the program.

    Stevo



  10. #10
    Registered
    Join Date
    Feb 2005
    Location
    Spain
    Posts
    7
    Downloads
    0
    Uploads
    0

    Default

    Itry the programation and don´t work



  11. #11
    Registered
    Join Date
    Jun 2008
    Location
    United States
    Posts
    1509
    Downloads
    0
    Uploads
    0

    Default

    So it still gives you the same alarm "NC alarm [191] Option command G80N Whith cycle for drilling" when you try to run the G83 cycle as I had suggested?

    I sent you a PM with address per request.

    Stevo



  12. #12
    Registered
    Join Date
    Aug 2011
    Location
    Canada
    Posts
    1
    Downloads
    0
    Uploads
    0

    Default

    Is it possible that you're machine doesn't have the can cycle option. I'm having a simular issue. My Hitachi Seiki HT 40 G (lathe) recently died, literally lost all param, sub prog, geo, grid position. Had to replace communication card that links the Fanuc drives to the Hitachi control. Now I'm trying to restore my machine and I'm getting the same NC Alarm [191]. Best I can tell, I need to reload the options onto the fanuc side, which requires info that I'm not privy to.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum from DIY CNC Machines to the Cad/Cam software to run them. The site is 100% free to join and use, so join today!

Follow us on

Facebook Dribbble RSS Feed