3dprintforums logo

CNCzone Network:  RFQwork :: 3Dprintforums :: Welderzone :: Google+ :: Our Facebook :: Twitter :: SiteMap



Results 1 to 8 of 8

Thread: Leadwell VMC25 ATC Trouble

  1. #1
    Registered resuengineering's Avatar
    Join Date
    Nov 2007
    Location
    Netherlands
    Posts
    63
    Downloads
    0
    Uploads
    0
    Rep Power
    7

    Leadwell VMC25 ATC Trouble

    I have a VMC25 with armless atc, controlled by a mitsubishi M50 control.

    the whole machine was empty of parameters,
    i reset it all by hand, but now how to reset the ATC???

    i wrote the 9001 program for it, and linked it with m6
    when i want to auto change tool, it goes to 1st ref point, orientates....
    atc is coming under spindle, tool unclamp.
    z-axis goes to 2nd ref point, atc starts rotating CCW endless....
    doesnt find any tool....

    do i need to reset the table or set a zero point.....

    please help

    Similar Threads:


  2. #2
    Registered EPTech's Avatar
    Join Date
    Mar 2009
    Location
    Belgium
    Posts
    33
    Downloads
    0
    Uploads
    0
    Rep Power
    0
    Hi,

    I own the exact same VMC from Leadwell. Maybe I can help. I will check my manuals to see if I can come up with some answer. We should get in touch to exchange ideas. I recently bought a servo controller (MDS-A-SVJ06) on ebay. I am going to try to attach my indexing table directly to the controller instead of the separate control box that came with it;

    But coming back to your issue. The current ATC position should be a register BYTE in the PLC in my language we call it a remanent marker. In other words something that is stored in non-volatile memory or backed up RAM. I am not sure if the actual address is referred to in the 9001 macro but it should be in the PLC program and one should be able to initialize it. I will look into it when I get back to my shop and will get back to you later.



  3. #3
    Registered
    Join Date
    Nov 2010
    Location
    USA
    Posts
    55
    Downloads
    0
    Uploads
    0
    Rep Power
    4

    Wink

    It sounds like one of 3 things may be wrong here.
    1) A chip on the ATC prox switch.(Can not find #1)
    2) The tool pot numbers in the ATC are not assigned in the parameters.(You may need ghost tool 99 in the empty spindle)
    3) The 9000 macro is incorrect.
    Mits controls are strange. Sometimes parameters have to be set in more than one place for a single function.
    If all else fails,try calling Campat Machine Tool in Plano,Tx. and ask for the service department. Be aware that they stopped importing Leadwells with the Mits control many years ago. Only Fanuc now.
    Good Luck-Dan



  4. #4
    Registered resuengineering's Avatar
    Join Date
    Nov 2007
    Location
    Netherlands
    Posts
    63
    Downloads
    0
    Uploads
    0
    Rep Power
    7
    @eptech

    this machine has also a extra mistu driver, i switched it down.
    it is possible to use a driver and set an extra axes

    mail me at resu @ draaitechniek dot nl

    the atc program runs until G0Z30Z0
    afther that the carousel keeps running to find the right tool.
    but never finds it

    --- ATC PROGRAM ---
    O9001(ATC )

    G4

    T#20

    G4P200

    IF[#1000EQ1]GOTO4

    IF[#1001EQ1]GOTO4

    M66

    G80

    #131=#4003

    #130=#4006

    G91G28Z0

    G49

    N1IF[#1002EQ0]GOTO1

    G30Z0P2

    N2IF[#1003EQ0]GOTO2

    G28Z0

    G#130

    G#131

    N3IF[#1004EQ0]GOTO3

    N4M67

    M99

    %



  5. #5
    Registered resuengineering's Avatar
    Join Date
    Nov 2007
    Location
    Netherlands
    Posts
    63
    Downloads
    0
    Uploads
    0
    Rep Power
    7
    i now know i need to set parameter R1984 but noway i can set it

    when i goto PLC I/F and set R1984 with data 0007 nothing happens
    all other formats give a E01 setting data wrond.

    do you need to set some other bits???



  6. #6
    Registered EPTech's Avatar
    Join Date
    Mar 2009
    Location
    Belgium
    Posts
    33
    Downloads
    0
    Uploads
    0
    Rep Power
    0
    Sorry it took me so long to get back to you. Holidays you know.

    In order to change anything on the PLC level, you need to stop the PLC program. You can do this on the machine interface itself but the easiest way is to open the display panel on the PLC itself and set the DIP switch to 1 if I remember correctly. The nice thing about the MELDAS controls is that one can fully program the PLC from the interface.



  7. #7
    Registered
    Join Date
    Aug 2012
    Location
    Sweden
    Posts
    1
    Downloads
    0
    Uploads
    0
    Rep Power
    0
    Hello everybody

    I am struggling with exactly the same problem as is described in the beginning of this thread on exactly the same type of machine, a Leadwell V25 with M50 control. Backup battery died during summer vacation and i have spent this last week with restoring it to functional again. I think this toolchange issue is the last one before we can get it running again.

    As described above, when running M06/9001 macro the carousel starts turning after the G30Z0P2 movement but the carousel never stops. I am guessing that the control has no clue about the carousel index.
    I have studied this thread among many others but here i find a clue i cannot sort out really. Its about:
    Quote Originally Posted by resuengineering View Post
    i now know i need to set parameter R1984 but noway i can set it

    when i goto PLC I/F and set R1984 with data 0007 nothing happens
    all other formats give a E01 setting data wrond.

    do you need to set some other bits???
    I have come to the conclusion that the position of the carousel must be initialized in some register since there is no pos1 sensor or similar for the carousel, only the step count sensor for the Geneve gear on input X7.

    - Is the R1984 register supposed to hold what tool position is facing the spindle at the moment? In such case, how should i format the data? Or is there some other way to initialize the carousel position?

    I have compete sets of manuals for the machine but cannot find anything that explains this to me. I also searched in the ladder logic for possible locations where the index might be stored but without any progress, i need to improve my PLC skills before new attempts.

    Any help about the carousel index would be highly appreciated, thanks



  8. #8
    Registered
    Join Date
    May 2013
    Location
    Ukraine
    Posts
    1
    Downloads
    0
    Uploads
    0
    Rep Power
    0
    I have the same problem and I find its solution. I think, register R1984 contains the number of tool in spindle, and R1954 -- carousel position. I simply wrote in both this registers current carousel position, and normal ATC operation resumed.
    Also, if anybody have VMC25 with MDS-A-SP-110 spindle drive, i would like to see its parameter set, because I have a trouble with spindle deceleration rate -- it is so fast, and when the spindle stopped from over 2800 rpm, it caused overvoltage in spindle drive. Anybody can help me? Simply download parameters to file (and make backup copy for youself ) and email it or attach to the post.



Posting Permissions



About CNCzone.com

    We are the largest and most active discussion forum from DIY CNC Machines to the Cad/Cam software to run them. The site is 100% free to join and use, so join today!

Follow us on

Facebook Dribbble RSS Feed