FANUC Series Oi-M - Flashing LSK / No DR Signal. RS232 Comm Issues?


Results 1 to 4 of 4

Thread: FANUC Series Oi-M - Flashing LSK / No DR Signal. RS232 Comm Issues?

  1. #1
    Registered
    Join Date
    Jun 2017
    Location
    Canada
    Posts
    2
    Downloads
    0
    Uploads
    0

    Question FANUC Series Oi-M - Flashing LSK / No DR Signal. RS232 Comm Issues?

    Hi everyone. It's my first post on these forums - go easy I apologize if I'm too wordy - I am just trying to be thorough to ensure I give you all the information that you may need.

    A friend of mine is having issues with his CNC controller and asked me to take a look. It is a FANUC Series Oi-M. When I first started looking at it, it was giving a "No DR Signal" error message. I replaced the USB to Serial device, and the error message is gone but now it flashes a yellow "LSK". One of the floor workers who was showing me to how to use the machine said that LSK means there is a loose connection somewhere to the computer but I didn't see one.

    I'm thinking that my best course of action is to:
    1. Purchase a Serial Tester so I can actually confirm the pinout and signal.
    2. Purchase a higher quality serial cable in order to rule out interference, signal loss, or damaged cable issues.



    Background:

    A friend of mine recently bought a cabinetmaking shop that has a few CNC machines with FANUC controllers.
    One of the controllers is a FANUC Series Oi-M. It seems to intermittently work and he's asked me to take a look at it.
    Some days the machine works fine, then it stops working. A few days go by and then it starts working again.
    Sometimes the workers say they wiggle one of the cables and it starts working, but I have been unable to replicate that myself.

    The computer doesn't have any serial ports, so it is using a USB to serial adapter.

    Here is the cabling components:


    • USB <----> DB9 Male
    • DB9 Female <-------> DB25 Male
    • DB25 Male <------> CNC Controller



    Here is the computer settings:


    • Its an XP machine. The comm software being used is AlphaEdit.
    • The USB adapter is configured to use COM6.
    • -COM6 is configured as 9600 baud. I forgot to take a photo but I believe it was in 7-E-1 mode .. it was definately 7 data bits.
    • In the software, Hardware Flow Control is enabled and Software Flow Control is disabled.
    • -There is an advanced option that says "Wait for XON before sending"... it is enabled .. (which seems strange to me since XON is software flow control, and we have that disabled .. oh well - I left it since that was the original setting)


    Usage

    The workers are loading the files off the network, and sending it to the CNC machine using AlphaEdit.

    The file looks something like:

    Code:
    START
    %
    01 (NEST_FAN_WHITE)
    (SHEET #1 OF 2)
    G17 G90 G21 G40 G80 M95
    G91 G28 Z0 M92
    G08 P1
    (TOOL #16)
    etc etc

    Sounds like a bunch of machine instructions to me .. go forward, back, move down, change tool, etc.

    The machine

    Turn Machine On (Big Green Button)
    Hit PROG button on the console
    Turn knob to the #1 setting
    Ensure it is on DIR screen.
    There are six soft keys under the screen. A left arrow on the left side, a right arrow on the right side, and four blank soft keys.
    In sequence we press #4 softkey (OPER on screen), Right Arrow, #1 softkey (READ), and then finally #4 softkey (EXEC)

    They tell me that it should then flash INPUT in the lower right.

    Instead, it was giving a No DR Signal error message.
    After I replaced the USB to serial adapter it only flashes "LSK" where it should be showing "INPUT".

    I went into the Parameters and I see that it is configured to use Channel 0. Channel 0 is set to 9600 baud.
    I wasn't sure how to tell where the Data Bits / Parity

    Similar Threads:
    Attached Thumbnails Attached Thumbnails FANUC Series Oi-M - Flashing LSK / No DR Signal.  RS232 Comm Issues?-fanuc_model-jpg  


  2. #2
    Registered
    Join Date
    Apr 2011
    Location
    USA
    Posts
    323
    Downloads
    0
    Uploads
    0

    Default Re: FANUC Series Oi-M - Flashing LSK / No DR Signal. RS232 Comm Issues?

    You might see if you can output a file from the CNC. I have found that USB to serial doesn't always play nice on the Fanuc CNC. Sometimes you can get away with it and sometimes you can't. I strictly use only computers with true serial ports and that means using older PCs.



  3. #3
    Gold Member dcoupar's Avatar
    Join Date
    Mar 2003
    Location
    USA
    Posts
    2877
    Downloads
    0
    Uploads
    0

    Default Re: FANUC Series Oi-M - Flashing LSK / No DR Signal. RS232 Comm Issues?

    I think the issue mostly rears it's ugly head with USB>Serial adapters that use "Prolific" drivers. To avoid this on computers that didn't have a built-in serial port, I've used aftermarket PCI serial cards, such as Siig. If you have an open PCI or PCI-e port, they have a card.



  4. #4
    Registered
    Join Date
    Jun 2017
    Location
    Canada
    Posts
    2
    Downloads
    0
    Uploads
    0

    Default Re: FANUC Series Oi-M - Flashing LSK / No DR Signal. RS232 Comm Issues?

    Quote Originally Posted by dcoupar View Post
    I think the issue mostly rears it's ugly head with USB>Serial adapters that use "Prolific" drivers. To avoid this on computers that didn't have a built-in serial port, I've used aftermarket PCI serial cards, such as Siig. If you have an open PCI or PCI-e port, they have a card.
    I was thinking of getting a PCI-E Serial card ... getting one with dual 16550 UARTS ...

    The machine has been working fine up until a couple of months ago - but who knows what has changed.

    I did try to replace the USB to Serial adapter but it didn't seem to fix it. The "Prolific" one is actually plugged in for talking to the OTHER fanuc - and that one seems to be working. Looking in the Prolific driver settings I see it has the 16550 Uart settings etc .. whereas the one I currently am using has nothing.

    Maybe the PCI-E Serial Card would be a good step to take.

    Thanks



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

FANUC Series Oi-M - Flashing LSK / No DR Signal.  RS232 Comm Issues?
FANUC Series Oi-M - Flashing LSK / No DR Signal.  RS232 Comm Issues?