New screen


Page 1 of 2 12 LastLast
Results 1 to 12 of 18

Thread: New screen

  1. #1
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default New screen

    New screen-uploadfromtaptalk1483407045557-jpgNew screen-uploadfromtaptalk1483407100803-jpg

    Tom I wanted you to see that your screen editor is not going to waste. The screen is 1920x1080. I will probably have a few questions about how to modify one of the mpg programs whichever is best. I would like to implement the mpg on my screen to enable/select axis/step size using virtual bits but hookup a hardware encoder for jogging. Also how to get some buttons to behave the way I would expect. Last is there a way to change the background image for kmcnc?

    Thanks
    Ben

    Sent from my HTC6525LVW using Tapatalk

    Similar Threads:


  2. #2
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Ok I have finally gotten a chance to use the screen I made. It works great but I have found a few issues. The cycle start and feedhold button images I created are not persistent. After starting the first cycle they revert to the original images that come with the program. It's worth noting I could not get the dotnet to load on the pc I'm running on so the screen was made on another pc. Any ideas on how to get things right would be great.

    Thanks
    Ben

    Sent from my HTC6525LVW using Tapatalk



  3. #3
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    2215
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Hi Ben,

    What Version are you running? I thought that issue was resolved in Version 4.34g with a new Button Type "DualButton". For the Cycle Start and FeedHold Buttons where KMotionCNC changes the image based on the machine state (rather than "pushed" state). See:

    http://dynomotion.com/Software/KMoti...%20Changes.pdf

    Regarding the background image: I'm not sure how useful that would be. But several Users have asked for it so we will probably add it. What were you thinking of? Here is one silly looking example:

    New screen-kmotioncncsteel-jpg

    Regards

    TK
    http://dynomotion.com


  4. #4
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Thanks for getting back so soon. I am using 433h. I will change the screen button type to dual buttons for those 2 and let you know how it goes. As for the background I was going to make a full screen underlay that give a 3d effect to each area so everything would be bracketed so to speak. The pictures I took really don't give the full effect but all my buttons are 3d so the screen has some depth. I made 2 images or more for every button on the screen so each one has a pressed state. If your interested in the screen or buttons let me know and I'll figure out how to send them on. There's 11mb worth of images. Over 200 total. If you need any special buttons made I can add them to the libraries pretty easy now that I have come up with a good system for creating them.

    Thanks
    Ben

    Sent from my HTC6525LVW using Tapatalk



  5. #5
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    I tried the dualbutton setting but still no dice. If you press either button they revert back until kmotion is restarted. Is there somewhere I can find the images used in kmotion and copy my own over top using the same name and format?

    Thanks
    Ben

    Sent from my HTC6525LVW using Tapatalk



  6. #6
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    2215
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Hi Ben,

    It seems to work for me see video below. Please tell us exactly what steps you are doing and what happens.



    Regards

    TK
    http://dynomotion.com


  7. #7
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    I believe it's most likely the crazy way I installed the program on the Windows 7 pc that is at issue. I have decided to install Windows 8 since I have a new unused copy that's been laying around for years. That will allow me to have the screen editor on the machine pc. Hopefully this will fix my issues.

    Thanks again
    Ben

    Sent from my HTC6525LVW using Tapatalk



  8. #8
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    2215
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Hi Ben,

    The Screen Editor should run on any OS beyond XP.

    Regards

    TK
    http://dynomotion.com


  9. #9
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    I have 2 different pc's with Windows 7 64 bit that I can't get to install the .net and other software that comes with kmotion for any reason. I tried everything I saw people mention trying in the Yahoo forum and I couldn't get any of that to work either. The pc's even refuse to read the signed drivers as well. I finally got kmotion loaded by turning off driver signature enforcement. But that's all it would load. As you can tell it's been driving me crazy.

    Ben

    Sent from my HTC6525LVW using Tapatalk



  10. #10
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    After switching to Windows 8 things are working exactly like the video. I am aware that the issues I was having we're not caused by the kmotion software.

    Thanks
    Ben

    Sent from my HTC6525LVW using Tapatalk



  11. #11
    Gold Member TomKerekes's Avatar
    Join Date
    May 2006
    Location
    USA
    Posts
    2215
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Hi Ben,

    Strange there was so much trouble with W7.

    Thanks for posting back.

    Regards

    TK
    http://dynomotion.com


  12. #12
    Registered
    Join Date
    Jun 2013
    Location
    USA
    Posts
    924
    Downloads
    0
    Uploads
    0

    Default Re: New screen

    Tom I have run into a new issue. I can run my machine through the warm-up routine as many times as I like and everything runs great. When I run the g-code for my current project I have a runaway every time. Always at the same spot in the code running a large circle. My first thought was a bad encoder but now I'm not so sure. The console gave me conflicting messages. The actual results varied during the runaway. Sometimes x would disable others it was y or both that disabled. Never z. Sometimes the dro would change to weird characters. Here are some pics.



    Not sure where to go from here.

    Thank you
    Ben

    Sent from my HTC6525LVW using Tapatalk



Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

New screen
New screen