3dprintforums logo

CNCzone Network:  RFQwork :: 3Dprintforums :: Welderzone :: Google+ :: Our Facebook :: Twitter :: SiteMap



Results 1 to 12 of 12

Thread: Problems aligning motor with lead screw.

  1. #1
    Registered
    Join Date
    Nov 2004
    Location
    US
    Posts
    39
    Downloads
    0
    Uploads
    0
    Rep Power
    0

    Problems aligning motor with lead screw.

    I put together a DIY 3 axis cnc machine and am having trouble getting the lead screws aligned with the motors. I drilled 1/2" rolled steel 3/4"long and tapped the motor end of it for the set screw. I tack welded the lead screw (1/4" all thread) to the coupler. I cant seem to get those things straight. They are causing me wobble problems on all 3 axis. I also need an easy way to measure my backlash so that the software can compensate. Any ideas? This is my own design and my first run, but its been fun so far. I just need to work on accuracy now. I am using pairs of ball bearing drawer slides that I got from work. They are server rack slides, so they are pretty heavy duty I think. The x and y are using 15" slides and the z uses 8" slides. Also, I am using an air powered rotery cutter. Is this sufficient or do I need to mount my 1.5hp router? My current setup cuts mdf fine, but can a light weight like this cut aluminum? All suggestions are much welcomed.

    Thanks all!

    Similar Threads:


  2. #2
    Registered
    Join Date
    Aug 2004
    Location
    US
    Posts
    2839
    Downloads
    0
    Uploads
    0
    Rep Power
    12
    2 options....remove the leadscrews and turn the welded coupler on a lathe, find a flexible coupler there are some that allow a small degree of misalignment....but I suspect that you don't have a slight case of misalignment...you got runout error or wobble and if you can see it as low speeds it's pretty large.



  3. #3
    www.joescnc.com joecnc2006's Avatar
    Join Date
    Aug 2004
    Location
    usa
    Posts
    3176
    Downloads
    0
    Uploads
    0
    Rep Power
    13
    I used three set screws in mine, then when i got it aligned (thread rod and stepper) then i tightened the set screws, seemed to work so far.



  4. #4
    Registered
    Join Date
    Apr 2003
    Location
    Sedona, AZ
    Posts
    121
    Downloads
    0
    Uploads
    0
    Rep Power
    12
    Your alignment between your motor end of each screw and bearing end need to be exactly in alignment. The best way to do this no matter what the material (mfd, aluminum etc) is to drill your motor center mount/bearing shaft end mount holes at the same time by clamping the parts together and drilling together. If you have a design to make the bearing/mount adjustable, then do so. You can even overside your motor mount holes slightly to allow a little adjustment.
    You also may have bent screws. Roll them on a piece of glass (like a glass sliding door) and any bent shafting will show up. Take time to carefully straighten any you notice out.
    As far as couplers, get some cheap flexable couplers that will eliminate slight misalignment problems. I wouldn't recommend welding anything to to your shafts or screws as the heat can also cause warping, or in the case of the motor shafts, damage to motor seals or bearings. If you're on a budget, something as simple as a 2-3 inch piece of stiff flexable hose/tubing (like fuel line for autos) with the correct inside diameter as your shaft/screw and a couple of good hose clamps will work. On my first machine I just epoxied the piece of tubing onto my cheap allthread "screw" and then double clamped the other tubing end to the motor shaft... it never came loose or slipped.
    Good luck!
    -marc



  5. #5
    Registered
    Join Date
    Jan 2004
    Location
    United States
    Posts
    490
    Downloads
    0
    Uploads
    0
    Rep Power
    11
    You say that you tack welded the coupler to the lead screw? Sounds to me like the lead screw is now warped from the welding process. Even just a little, seemingly harmless tack weld will do this to a degree, the size of which dependent on how hefty the material being welded is. I suggest getting some flexible couplers. No you dont have to spend tons of money on them, re-inforced plastic tubing, with a couple of clamps works fine.

    Stop talking about it and do it already!!!!!

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  6. #6
    Registered
    Join Date
    Nov 2004
    Location
    US
    Posts
    39
    Downloads
    0
    Uploads
    0
    Rep Power
    0
    The tubing sounds like a good idea and I already have that stuff laying around, so i'll give that a try and let you know how it works.


    Thanks guys!



  7. #7
    Registered
    Join Date
    Dec 2004
    Location
    USA
    Posts
    174
    Downloads
    0
    Uploads
    0
    Rep Power
    10
    Lovejoy makes some small couplers that cost about $5 per axis for the three components, I used these they are accurate and easy.

    Attached Thumbnails Attached Thumbnails -lovejoy-coupling-detail-jpg  


  8. #8
    Registered pminmo's Avatar
    Join Date
    Jun 2003
    Location
    St. Peters, Mo USA
    Age
    61
    Posts
    3309
    Downloads
    0
    Uploads
    0
    Rep Power
    14
    where can you buy the Lovejoy couplers?

    Phil, Still too many interests, too many projects, and not enough time!!!!!!!!
    Vist my websites - http://pminmo.com & http://millpcbs.com


  9. #9
    Registered
    Join Date
    Dec 2004
    Location
    USA
    Posts
    174
    Downloads
    0
    Uploads
    0
    Rep Power
    10
    These are Lovejoy L050 components that I got from Enco USE-ENCO.com, phone 1(800)8733626, cost about $5.15 for the three component assembly. These will take up to 3/4 hp @18000 rpm, 26.3in./lbs. torque, and allow some misalignment. There is very little/no free play on the acme shaft or motor shaft hubs. There are other sizes available up to 5/8 in.
    Enco pns
    1/4 in bore hub, 990-4044, $1.94, mfg. M646220
    1/2 in bore hub, 990-4046, $1.94, mfg. M735580
    buna N spider, 990-4042, $1.27, mfg. P00CH



  10. #10
    Registered jeffs555's Avatar
    Join Date
    Jun 2004
    Location
    United States
    Posts
    463
    Downloads
    0
    Uploads
    0
    Rep Power
    10
    How much backlash do you get on the Lovejoy couplings? I just looked at some L100's at a local hydraulics supply, and they seemed to have an awful lot of backlash/freeplay. They appear to be designed for coupling a motor to pumps and things where backlash is not a concern.



  11. #11
    Community Moderator ger21's Avatar
    Join Date
    Mar 2003
    Location
    Shelby Twp, MI....USA
    Posts
    23816
    Downloads
    0
    Uploads
    0
    Rep Power
    35
    If you search for flexible couplings at McMaster Carr, you'll find quite a few options. They list spider couplings, which look like the Lovejoys above, Oldham couplings, slotted disc, helical beam. All are claimed to have zero backlash, and range from a few dollars each up to around $25-30 for the helical.

    Gerry

    Mach3 2010 Screenset
    http://home.comcast.net/~cncwoodworker/2010.html

    (Note: The opinions expressed in this post are my own and are not necessarily those of CNCzone and its management)


  12. #12
    Registered
    Join Date
    Dec 2004
    Location
    USA
    Posts
    174
    Downloads
    0
    Uploads
    0
    Rep Power
    10
    The spider is a real tight fit, actually some preload so zero play. There are various hardness of the spiders that range to pretty soft, the buna N are on the stiff side. These are a very common industrial coupler, I use them, and specify them, to couple hydraulic pump/motors.



Tags for this Thread

Posting Permissions



About CNCzone.com

    We are the largest and most active discussion forum from DIY CNC Machines to the Cad/Cam software to run them. The site is 100% free to join and use, so join today!

Follow us on

Facebook Dribbble RSS Feed