Newbie GCODE Z-height zero changes during cut


Results 1 to 5 of 5

Thread: GCODE Z-height zero changes during cut

  1. #1
    Registered
    Join Date
    Aug 2017
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default GCODE Z-height zero changes during cut

    Hello,

    (bear with me i am new to all this) i am just messing about learning my routers feeds, speeds and software etc and all was going well until tonight.

    I have a old chopping board sitting about and wanted to carve on a "Beef cuts" chart - i just did a quick bitmap to vector, did a v-bit path and during the cut the Z-Height zero goes to pot and ends up being 10mm higher than where i zeroed it at the start meaning it only cuts half the model.

    i have re-done the paths twice and re-loaded it etc a few times but still goes all tits up, but i dont think its the machine or Mach3 as i cut a few things after and they went through fine.

    anyone got any ideas what i may be doing wrong?

    here are links to the files;
    https://drive.google.com/open?id=0By...GM0VzlzY1BsdnM
    https://drive.google.com/open?id=0By...nRPVGJDSkhSRnM


    Similar Threads:


  2. #2
    Gold Member
    Join Date
    Jul 2005
    Location
    USA
    Posts
    2380
    Downloads
    0
    Uploads
    0

    Default Re: GCODE Z-height zero changes during cut

    What does the Z DRO say you are at? With no idea of what controller you have its not possible to give much guidance. If its the g-code the DRO position would show to be at the wrong height. If your Z does not match the DRO then you have some how gained steps (not real easy to do) . It Might indicate a loose coupler but it might also be a problem from noise getting to your Z driver. ANy time the actual postion is different than the DRO position then you have either gained or lost mechanical position. Normally lost steps occur on the up lift on Z and it ends up LOWER than the Z indicates. Gaining position would me its getting steps not being sent by the software OR you are losing steps going down....not likely



  3. #3
    Registered
    Join Date
    Aug 2017
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: GCODE Z-height zero changes during cut

    Hello Torchhead, thanks for the reply - I am using a "generic Chineseium" controller for the time being until my new one turns up from the USA, and I am setting Z-Height in Mach3 - I ran it once more and for a third time at exactly the same spot it had cut the outlines and moved onto the words - it went to move to the other side of the workpiece and as the gantry was moving the Z-Height started changing on the mach3 readout but not on the machine - the router bit stayed at 10mm high but by the time it got to the other side Mach 3 thought it was at zero (despise being 10mm high) - I would guess it was a wiring problem or similar but it only does it on this model - even if I start over again in artcam it does it again at exactly the same spot??? It's driving me wild as I think it must be something I am doing wrong somewhere?


    Sent from my iPhone using Tapatalk



  4. #4
    Gold Member
    Join Date
    Jul 2005
    Location
    USA
    Posts
    2380
    Downloads
    0
    Uploads
    0

    Default Re: GCODE Z-height zero changes during cut

    I will attempt to simplify: You are losing steps (The motor is not moving one step for every step the software is sending)
    IF the DRO shows it moved then the software has sent the pulse to move it....it has no way to know if it actually moved or not. Outlines do not have a lot of rapid up and down moves where as letters( if not flat sides and top) have lots of up and down moves Cutting reliefs in ArtCAM is an intensive process of lots of short moves.

    Slow the max velocity and acceleration down on Z. Drop it by 50% as a test. If the problem persists then
    Consider using a real controller. The problems with Cheap Chinese motor drivers/controls are legendary.



  5. #5
    Registered
    Join Date
    Aug 2017
    Location
    United Kingdom
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: GCODE Z-height zero changes during cut

    Quote Originally Posted by Torchhead View Post
    I will attempt to simplify: You are losing steps (The motor is not moving one step for every step the software is sending)
    IF the DRO shows it moved then the software has sent the pulse to move it....it has no way to know if it actually moved or not. Outlines do not have a lot of rapid up and down moves where as letters( if not flat sides and top) have lots of up and down moves Cutting reliefs in ArtCAM is an intensive process of lots of short moves.

    Slow the max velocity and acceleration down on Z. Drop it by 50% as a test. If the problem persists then
    Consider using a real controller. The problems with Cheap Chinese motor drivers/controls are legendary.
    Thanks! I understand what you mean now and it would make sense as there is a lot of up and down in this one. Much appreciated.

    I have heard bad things about the controller , although I have found it to be fine until now - either way I have a Gecko on its way so fingers crossed it is here soon!


    Sent from my iPhone using Tapatalk



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About CNCzone.com

    We are the largest and most active discussion forum for manufacturing industry. The site is 100% free to join and use, so join today!

Follow us on


Our Brands

GCODE Z-height zero changes during cut
GCODE Z-height zero changes during cut